Can't select PHP Version fr om Selector PHP
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Havri
  2. Thursday, 03 November 2016
  3.  Subscribe via email
Hello,

I am currently trying to get this fixed, as I cannot select any version using Selector PHP. The install commands for the packages were the following:


yum install cagefs --enablerepo=cloudlinux-updates-testing
yum install lve-stats --enablerepo=cloudlinux-updates-testing
yum install lvemanager --enablerepo=cloudlinux-updates-testing
yum groupinstall alt-php --enablerepo=cloudlinux-updates-testing


The error I get is the one below:

Unable to set version native for user useless: ([Errno 13] Permission denied)


Any idea how I can get this solved? Or what logs do I have to check?


P.S. Now it seems that Cloudlinux repo is down, as I'm not able to install anything. Some errors below:

Unable to connect to the host and port specified
  alt-php54-enchant-5.4.45-24.el6.x86_64: Error communicating with server. The message was:
Unable to connect to the host and port specified
  alt-php53-xmlrpc-5.3.29-40.el6.x86_64: Error communicating with server. The message was:
Unable to connect to the host and port specified


Thanks.
Rate this post:
  1. 03.11.2016 19:11:22
  2. # 1
Havri Accepted Answer
Posts: 26
Joined: 30.07.2015
0
Votes
Undo
Hello,

Long story, short, I had activated a kernel option, recommended by Cloudlinux:


fs.protected_symlinks_create = 1
fs.protected_hardlinks_create = 1

This prevents users from creating symlinks to other files and folders not owned by them, which includes those of PHP Selector.

In my case, the problem was that \"fs.protected_symlinks_allow_gid\" and \"fs.protected_hardlinks_allow_gid\" had wrong values in /etc/sysctl.conf. The correct value should be the value returned from the following command, which is the Group ID for \"linksafe\":

grep \"linksafe\" /etc/group | awk -F\':\' \'{print $3}\'

After updating \"fs.protected_symlinks_allow_gid\" and \"fs.protected_hardlinks_allow_gid\" with the value for \"linksafe\" GID, I ran sysctl -p.

After that, I was able to reinit and/or update CageFS and sel ect different versions of PHP fr om within Selector PHP in users\' cPanel.
Hope this helps somebody.
  1. 03.11.2016 10:11:29
  2. # 2
Havri Accepted Answer
Posts: 26
Joined: 30.07.2015
0
Votes
Undo
Hi,

I opened a support ticket, as you requested.
Update: Cloudlinux repo seems to be up again, as yum install works again.
  1. 03.11.2016 09:11:15
  2. # 3
Igor Ghertesco Accepted Answer
Posts: 153
Joined: 07.08.2015
0
Votes
Undo
Hello,

Could you please create a ticket in our helpdesk? https://helpdesk.cloudlinux.com

We will check the issue
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.