Strange Server Wide Wordpress Issue
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Mark Sheppard
  2. Saturday, 03 September 2016
  3.  Subscribe via email
Hi Everyone,
I have a recent server wide issue that i can\'t seem to find a solution for but only started after a cloudlinux update. All my WordPress site are unable to publish new content almost like it is blocked or something. When trying to post anything new the only options that are available are draft and pending review and this is now a server wide issue, any help would be much appreciated.


Rate this post:
  1. 04.09.2016 05:09:55
  2. # 1
Baby Accepted Answer
Posts: 23
Joined: 04.10.2012
The issue you have described is unlikely to have anything at all to do with CloudLinux. Rather, it’s likely that your affected WordPress sites are running a plugin or theme that is causing this issue.

Try renaming the 'plugins' folder (inside the 'wp-content' folder) for one of the affected sites to something else, like 'plugins.disabled'. Then sign in to that site’s WordPress admin dashboard and see if you can publish new content.

(a) If it works, you’ll need to enable the plugins one at a time (whilst also testing the publishing each time, of course) to find out exactly which plugin is causing the problem.
(b) If it still doesn’t work after you rename the 'plugins' folder, it’s possible that the theme is causing the issue. In that case, try selecting a different theme (whilst still having all plugins disabled), preferably one of the default themes, and see if you’re now able to publish.
  1. 05.09.2016 07:09:47
  2. # 2
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
Hi Baby,
It is definitely a server issue, I have done everything you suggested numerous times and did not change anything. The fact the same issue is happening to all the WordPress sites hosted on my server and has only recently started would suggest it is a server issue.  
  1. 05.09.2016 11:09:12
  2. # 3
Richard Hordern Accepted Answer
Posts: 212
Joined: 19.03.2011
Have you tried enabeling WordPress\'s debug mode in wp-config.php ? This might give you some more information about why this is happening.

This could be a PHP extension required by WordPress either failing or not being enabled.

I presume you have PHP Selector, if so have you tried changing PHP versions to see if it resolves the issue, and also maybe switching from mysql to mysqlnd on that account to see if that changes anything.
  • Page :
  • 1

There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.