Trying to run let's encrypt in cloud linux 7
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. ramesh bh
  2. Wednesday, 27 April 2016
  3.  Subscribe via email
let's encrypt, cloudlinux 7
Rate this post:
  1. 27.04.2016 03:04:01
  2. # 1
ramesh bh Accepted Answer
Posts: 1
Joined: 27.04.2016
0
Votes
Undo
Hi,
I am trying to run let's encrypt in my cloudlinux 7  server but it is giving the following error when i run it 

[email protected] [~]# ./letsencrypt/letsencrypt-auto 
Bootstrapping dependencies for RedHat-based OSes...
yum is /usr/bin/yum
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
 * cloudlinux-x86_64-server-7: de-proxy.cl-mirror.net
 * epel: mirrors.n-ix.net
Package python-2.7.5-34.el7.x86_64 already installed and latest version
Package python-devel-2.7.5-34.el7.x86_64 already installed and latest version
Package python-tools-2.7.5-34.el7.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package python-pip.noarch 0:7.1.0-1.el7 will be installed
---> Package python-virtualenv.noarch 0:1.10.1-2.el7 will be installed
--> Processing Conflict: alt-python-virtualenv-1.11.6-2.el7.cloudlinux.noarch conflicts python-virtualenv
--> Finished Dependency Resolution
Error: alt-python-virtualenv conflicts with python-virtualenv-1.10.1-2.el7.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
 * cloudlinux-x86_64-server-7: de-proxy.cl-mirror.net
 * epel: mirrors.n-ix.net
No package python27 available.
No package python27-devel available.
No package python27-virtualenv available.
No package python27-tools available.
No package python27-pip available.
Error: Nothing to do
Could not install Python dependencies. Aborting bootstrap!

there is already python installed, but the package name is  alt-python27.x86_64, 
what can be done.
  1. 27.04.2016 15:04:48
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hi,

I worry python-virtualenv and alt-python-virtualenv will not work together... So far there is no nice solution for this, I am creating bugreport to our developers to try adding \'Provides: python-virtualenv\' for our alt- package. Theoretically that will work, however it\'s to early to say for sure.
  1. 28.04.2016 15:04:12
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hey, we have just pushed alt-python-virtualenv-1.11.6-2.el7.cloudlinux.1 to beta repository and it works properly with letsencrypt . Please update it using \'--enablerepo=cloudlinux-updates-testing\' then try again.

Let us know how it goes.
  1. 04.05.2016 04:05:59
  2. # 4
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Did you tried it? Let us know how it goes.
  1. 04.05.2016 10:05:45
  2. # 5
Peter Grahn Accepted Answer
Posts: 14
Joined: 08.04.2016
0
Votes
Undo
I can flake in that I just installed Let\'s Encrypt for cPanel with the same config and it\'s working fine.

Yours.

Peter
  1. 05.07.2018 20:07:15
  2. # 6
henry skillz Accepted Answer
Posts: 0
Joined: 25.08.2019
0
Votes
Undo
hey help me im getting this error while installing certbot

..............
Running transaction check
---> Package e2fsprogs.x86_64 0:1.42.9-10.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.42.9-10.el7 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package libselinux-python.x86_64 0:2.5-11.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-12.el7 will be an update
---> Package libselinux-utils.x86_64 0:2.5-11.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-12.el7 will be an update
---> Package libsepol.x86_64 0:2.5-6.el7 will be updated
---> Package libsepol.x86_64 0:2.5-8.1.el7 will be an update
---> Package libss.x86_64 0:1.42.9-10.el7 will be updated
---> Package libss.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package python-pip.noarch 0:7.1.0-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-pip-7.1.0-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-pip-7.1.0-1.el6.noarch (epel)
Requires: python(abi) = 2.6
Installed: python-2.7.5-68.el7.x86_64 (@base)
python(abi) = 2.7
python(abi) = 2.7
Available: python34-3.4.8-1.el6.i686 (epel)
python(abi) = 3.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Could not install OS dependencies. Aborting bootstrap!
  1. 09.07.2018 08:07:13
  2. # 7
Igor Ghertesco Accepted Answer
Posts: 154
Joined: 07.08.2015
0
Votes
Undo
Hello,

Please provide me full output of # yum install certbot

and also the output of this command: # grep exclude /etc/yum.conf
  1. 09.07.2018 09:07:13
  2. # 8
myskillz Accepted Answer
Posts: 0
Joined: 25.08.2019
0
Votes
Undo
sorry ,, i did it.. but the problem now is i got warm emails from certbot but it still dont work

when i do http://www.isoko.ga this works

but https://www.isoko.ga is working very badly.. going elsewhere from the project spot, and its telling me that its not secure while i've already got emails
  1. 09.07.2018 12:07:30
  2. # 9
Igor Ghertesco Accepted Answer
Posts: 154
Joined: 07.08.2015
0
Votes
Undo
Hello,

I'm sorry, but certbot is not our product, we can not debug it. Most likely the SSL certificate wasn't installed correctly.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.