Yum error
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Eric Merkel
  2. Monday, 07 March 2016
  3.  Subscribe via email
The system failed to execute yum with the arguments
Rate this post:
  1. 07.03.2016 09:03:30
  2. # 1
Eric Merkel Accepted Answer
Posts: 15
Joined: 31.12.2014
0
Votes
Undo
I am seeing the following error on various CL cPanel servers. Is this an issue? Is it holding up future update of CL packages?


[2016-03-06 22:56:10 -0500]      [789616] --> Processing Dependency: kmod-lve >= 1.4 for package: lve-1.4-1.2.el6.cloudlinux.x86_64


[2016-03-06 22:56:10 -0500]      [789616] ---> Package lve-utils.x86_64 0:1.5-2.5.el6.cloudlinux will be updated

[2016-03-06 22:56:10 -0500]      [789616] ---> Package lve-utils.x86_64 0:1.5-2.8.el6.cloudlinux will be an update

[2016-03-06 22:56:10 -0500]      [789616] ---> Package openssl.x86_64 0:1.0.1e-42.el6_7.2 will be updated

[2016-03-06 22:56:10 -0500]      [789616] ---> Package openssl.x86_64 0:1.0.1e-42.el6_7.4 will be an update

[2016-03-06 22:56:10 -0500]      [789616] ---> Package openssl-devel.x86_64 0:1.0.1e-42.el6_7.2 will be updated

[2016-03-06 22:56:10 -0500]      [789616] ---> Package openssl-devel.x86_64 0:1.0.1e-42.el6_7.4 will be an update

[2016-03-06 22:56:10 -0500]      [789616] ---> Package postgresql-libs.x86_64 0:8.4.20-4.el6_7.cloudlinux will be updated

[2016-03-06 22:56:10 -0500]      [789616] ---> Package postgresql-libs.x86_64 0:8.4.20-5.el6_7.cloudlinux will be an update

[2016-03-06 22:56:10 -0500]      [789616] --> Finished Dependency Resolution

[2016-03-06 22:56:10 -0500]      [789616] Error: Package: lve-1.4-1.2.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)

[2016-03-06 22:56:10 -0500]      [789616]  You could try using --skip-broken to work around the problem

[2016-03-06 22:56:10 -0500]      [789616]  You could try running: rpm -Va --nofiles --nodigest

[2016-03-06 22:56:10 -0500]      [789616] (XID 3bytpa) The system failed to execute yum with the arguments “-y -c /etc/yum.conf update” because of an error: The “/usr/bin/yum” command (process 789893) reported error number 1 when it ended. : Error: Package: lve-1.4-1.2.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)




Eric
  1. 07.03.2016 09:03:46
  2. # 2
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
Same problem here.  Been happening since around Feb 29th.

- Scott
  1. 08.03.2016 11:03:23
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Could you please provide me with the output of the following:

rpm -qa | egrep \'kernel-|kmod-lve\' | sort
  1. 08.03.2016 12:03:43
  2. # 4
Eric Merkel Accepted Answer
Posts: 15
Joined: 31.12.2014
0
Votes
Undo
Here ya go...


dracut-kernel-004-388.el6.noarch
kernel-2.6.32-531.23.3.lve1.2.66.el6.x86_64
kernel-2.6.32-531.29.2.lve1.3.11.1.el6.x86_64
kernel-firmware-2.6.32-604.30.3.lve1.3.63.el6.noarch
kernel-headers-2.6.32-604.30.3.lve1.3.63.el6.x86_64
kmod-lve-1.3-11.1.el6.x86_64
kmod-lve-2.6.32-531.23.3.lve1.2.66.el6.x86_64-1.2-72.el6.x86_64
kmod-lve-2.6.32-531.29.2.lve1.3.11.1.el6.x86_64-1.3-11.1.el6.x86_64

Eric
  1. 08.03.2016 12:03:50
  2. # 5
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Ok, I understand the issue now. You are using older kernel packages while lve-1.4-1.2 require some newer.  I am going to report this to our developers however as a quick workaround you may add 'lve' to exclude in /etc/yum.conf file.

Will update you all when I will have any news about this.
  1. 21.03.2016 09:03:16
  2. # 6
Eric Merkel Accepted Answer
Posts: 15
Joined: 31.12.2014
0
Votes
Undo
Any updates on this? Should I just add lve* to the yum.conf? I tried this and now this is the error I am seeing.


[2016-03-21 09:29:40 -0400]      [309993] Error: Package: liblve-1.4-1.3.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993] Error: Package: cagefs-5.5-6.9.3.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]  You could try using --skip-broken to work around the problem
[2016-03-21 09:29:40 -0400]      [309993]  You could try running: rpm -Va --nofiles --nodigest
[2016-03-21 09:29:40 -0400]      [309993] (XID 6g9q7d) The system failed to execute yum with the arguments “-y -c /etc/yum.conf update” because of an error: The “/usr/bin/yum” command (process 310006) reported error number 1 when it ended. : Error: Package: liblve-1.4-1.3.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]            Requires: lve = 1.4-1.3.el6.cloudlinux
[2016-03-21 09:29:40 -0400]      [309993]            Installed: lve-1.3-1.10.el6.cloudlinux.x86_64 (@cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]                lve = 1.3-1.10.el6.cloudlinux
[2016-03-21 09:29:40 -0400]      [309993] Error: Package: cagefs-5.5-6.9.3.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]            Requires: lve-utils >= 1.5-2.8
[2016-03-21 09:29:40 -0400]      [309993]            Installed: lve-utils-1.5-2.5.el6.cloudlinux.x86_64 (@cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]                lve-utils = 1.5-2.5.el6.cloudlinux
[2016-03-21 09:29:40 -0400]      [309993] Error: Package: cagefs-5.5-6.9.3.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]            Requires: lve-wrappers >= 0.6-11
[2016-03-21 09:29:40 -0400]      [309993]            Installed: lve-wrappers-0.6-9.el6.cloudlinux.x86_64 (@cloudlinux-x86_64-server-6)
[2016-03-21 09:29:40 -0400]      [309993]                lve-wrappers = 0.6-9.el6.cloudlinux
[2016-03-21 09:29:40 -0400]      [309993] checkyum version 22.3



Best regards,
Eric
  1. 22.03.2016 06:03:34
  2. # 7
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Unfortunately there is no \'nice\' solution for this. Latest packages from CloudLinux required updated kernel. The only one right solution is to use latest kernel.
  1. 22.03.2016 07:03:36
  2. # 8
Eric Merkel Accepted Answer
Posts: 15
Joined: 31.12.2014
0
Votes
Undo
Well how would I go about doing that? I mean when we install CloudLinux and it installs the kernel you provide on your web site. Should it not auto-update to the latest kernel? Do I maybe just need to reboot?

Best regards,
Eric
  1. 22.03.2016 14:03:04
  2. # 9
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Auto-update shoudl always work. Maybe something is excluded in /etc/yum.conf file and it block update process. Looks like my previous post was to hasty. I would like to check the issue more deep, could you please create support ticket at https://helpdesk.cloudlinux.com ?
  1. 22.03.2016 14:03:59
  2. # 10
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
We had the same problem here, and solved it by changing the order in which we updated things.  i.e. we did a few things at a time, instead of trying to do everything at once with yum update all.  I can't recall the order, but that was the solution.

- Scott
  1. 05.05.2016 04:05:30
  2. # 11
Chuck Brown Accepted Answer
Posts: 1
Joined: 05.05.2016
0
Votes
Undo
Is there anyone who can document out what they have done to fix this? I have a customer who when trying to upgrade we keep hitting hangups and reboots of the latest kernel is a kernel panic. Here's what happens when we try to update Yum:


Error: Package: cagefs-5.5-6.22.2.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
           Requires: lve-wrappers >= 0.6-11
           Installed: lve-wrappers-0.6-9.el6.cloudlinux.x86_64 (@cloudlinux-x86_64-server-6)
               lve-wrappers = 0.6-9.el6.cloudlinux
Error: alt-php44 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php56 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php53 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php70 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: cagefs conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php52 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php54 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: alt-php51 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: Package: cagefs-5.5-6.22.2.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
           Requires: lve-utils >= 1.5-2.8
           Installed: lve-utils-1.5-2.5.el6.cloudlinux.x86_64 (@cloudlinux-x86_64-server-6)
               lve-utils = 1.5-2.5.el6.cloudlinux
Error: alt-php55 conflicts with lvemanager-1.0-9.9.10.el6.cloudlinux.noarch
Error: cagefs conflicts with liblve-1.3-1.10.el6.cloudlinux.x86_64
 You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
alt-php51-common-5.1.6-52.el6.x86_64 is a duplicate with alt-php51-common-5.1.6-45.el6.x86_64
alt-php51-pdo-5.1.6-52.el6.x86_64 is a duplicate with alt-php51-pdo-5.1.6-45.el6.x86_64
alt-php52-common-5.2.17-79.el6.x86_64 is a duplicate with alt-php52-common-5.2.17-72.el6.x86_64
alt-php52-pdo-5.2.17-79.el6.x86_64 is a duplicate with alt-php52-pdo-5.2.17-72.el6.x86_64
alt-php53-common-5.3.29-29.el6.x86_64 is a duplicate with alt-php53-common-5.3.29-22.el6.x86_64
alt-php53-pdo-5.3.29-29.el6.x86_64 is a duplicate with alt-php53-pdo-5.3.29-22.el6.x86_64
alt-php54-common-5.4.45-14.el6.x86_64 is a duplicate with alt-php54-common-5.4.45-5.el6.x86_64
alt-php54-pdo-5.4.45-14.el6.x86_64 is a duplicate with alt-php54-pdo-5.4.45-5.el6.x86_64
1:alt-php55-common-5.5.34-1.el6.x86_64 is a duplicate with 1:alt-php55-common-5.5.32-0.1.el6.x86_64
1:alt-php55-pdo-5.5.34-1.el6.x86_64 is a duplicate with 1:alt-php55-pdo-5.5.32-0.1.el6.x86_64
alt-php56-common-5.6.20-1.el6.x86_64 is a duplicate with alt-php56-common-5.6.18-0.1.el6.x86_64
alt-php56-pdo-5.6.20-1.el6.x86_64 is a duplicate with alt-php56-pdo-5.6.18-0.1.el6.x86_64
alt-php70-common-7.0.5-1.el6.x86_64 is a duplicate with alt-php70-common-7.0.3-0.1.el6.x86_64
alt-php70-pdo-7.0.5-1.el6.x86_64 is a duplicate with alt-php70-pdo-7.0.3-0.1.el6.x86_64
file-libs-5.04-30.el6.x86_64 is a duplicate with file-libs-5.04-21.el6.x86_64
kernel-2.6.32-673.8.1.lve1.4.3.el6.x86_64 has missing requires of kmod-e1000e-2.6.32-673.8.1.lve1.4.3.el6.x86_64
kernel-firmware-2.6.32-673.8.1.lve1.4.3.el6.noarch is a duplicate with kernel-firmware-2.6.32-604.30.3.lve1.3.63.el6.noarch
kmod-lve-1.4-3.1.el6.x86_64 is a duplicate with kmod-lve-1.3-63.el6.x86_64
krb5-libs-1.10.3-42z1.el6_7.x86_64 is a duplicate with krb5-libs-1.10.3-42.el6.x86_64
libldb-1.1.25-2.el6_7.x86_64 is a duplicate with libldb-1.1.13-3.el6_7.1.x86_64
liblve-1.4-1.3.el6.cloudlinux.x86_64 is a duplicate with liblve-1.3-1.10.el6.cloudlinux.x86_64
libsss_idmap-1.12.4-47.el6_7.8.x86_64 is a duplicate with libsss_idmap-1.12.4-47.el6_7.7.x86_64
libtalloc-2.1.5-1.el6_7.x86_64 is a duplicate with libtalloc-2.0.7-2.el6.x86_64
libtdb-1.3.8-1.el6_7.x86_64 is a duplicate with libtdb-1.2.10-1.el6.x86_64
libtevent-0.9.26-2.el6_7.x86_64 is a duplicate with libtevent-0.9.18-3.el6.x86_64
lve-1.4-1.3.el6.cloudlinux.x86_64 is a duplicate with lve-1.3-1.10.el6.cloudlinux.x86_64
1:mod_ssl-2.2.15-26.el6.cloudlinux.1.x86_64 has missing requires of httpd = ('0', '2.2.15', '26.el6.cloudlinux.1')
1:mod_ssl-2.2.15-26.el6.cloudlinux.1.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
nspr-4.11.0-0.1.el6_7.x86_64 is a duplicate with nspr-4.10.8-2.el6_7.x86_64
nss-util-3.21.0-0.3.el6_7.x86_64 is a duplicate with nss-util-3.19.1-2.el6_7.x86_64

Any suggestions on how to get things upgraded so he's running smoothly again?
  1. 09.05.2016 09:05:56
  2. # 12
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hello Chuck,

Please create support ticket at https://helpdesk.cloudlinux.com , I suppose there is some mix of stable/beta packages and they are conflicting. However definitely they should not cause kernel panic. Really better to talk with support directly.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.