Random 503 errors after alt-php updates
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Morten
  2. Monday, 15 June 2020
  3.  Subscribe via email
Hello,

We have customers contacting us about their site suddenly get 503 errors.
Cloudlinux have checked this, but didn't find any cause why this happens on different servers/accounts all the time.

Does anyone else have the same issue?
The way to fix the error is just to reset the php extensions in cPanel or just change the php version and back again.

So it's clearly a bug in cloudlinux's software, but they cannot figure out what and why is causing this.

From Apache error_log when 503 error:
[Mon Jun 15 09:01:14.149694 2020] [lsapi:error] [pid 1263147:tid 23337247778560] [client XX.XX.XX:53395] [host Domain.tld] Error on sending request(GET /favicon.ico HTTP/2.0); uri(/index.php) content-length(0): ReceiveAckHdr: nothing to read from backend (LVE ID 2727), check http://docs.cloudlinux.com/mod_lsapi_troubleshooting.html, referer: https://domain.tld/
Rate this post:
  1. 15.06.2020 09:06:13
  2. # 1
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Hello Morten,
Thank you for reaching out! This error indicates that the PHP script was not executed and it does not seem to be related to the update. Please try to enable the logging of PHP errors. The output will indicate script errors or a lack of memory.
If all the same there was a problem with the update - roll back the update through yum history.
If this does not help, could you please open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new and our technical experts will help you asap
Thank you.
Marketing Manager
  1. 15.06.2020 09:06:00
  2. # 2
Morten Accepted Answer
Posts: 116
Joined: 16.04.2014
0
Votes
Undo
Logging of customers WP installation is on, but nothing there as this is on the server.
We cannot roll back all servers all the time. We need to do updates on the servers from time to time.
  1. 15.06.2020 09:06:28
  2. # 3
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Logging of customers WP installation is on, but nothing there as this is on the server.
We cannot roll back all servers all the time. We need to do updates on the servers from time to time.

Morten,
Can you open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new so we can take a closer look at your system? You can post the ticket number here and we'll link this thread to it.
Thank you.
Marketing Manager
  1. 15.06.2020 10:06:00
  2. # 4
Morten Accepted Answer
Posts: 116
Joined: 16.04.2014
0
Votes
Undo
Ticket #81608 from some months ago.
And ticket #88608.
  1. 15.06.2020 10:06:55
  2. # 5
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Ticket #81608 from some months ago.
And ticket #88608.

Thank you, our specialists will answer you on the ticket as quickly as possible.
Marketing Manager
  1. 08.08.2020 00:08:14
  2. # 6
Jefferson Zardo Accepted Answer
Posts: 1
Joined: 08.08.2020
0
Votes
Undo
Hi, did this issue had to a resolution? I have the same problem. Thanks
  1. 10.08.2020 13:08:57
  2. # 7
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Hi, did this issue had to a resolution? I have the same problem. Thanks

Hello Jefferson,
Can you open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new so we can take a closer look at your system? And technical experts will help you asap. If you have any other questions, feel free to ask here.
Thank you for contacting us.
Marketing Manager
  1. 10.08.2020 14:08:04
  2. # 8
Morten Accepted Answer
Posts: 116
Joined: 16.04.2014
0
Votes
Undo
Hello,

No solution yet. CL doesnt seem to find any solution yet. They Just asks us to try different things each time?
We didnt have this issue last year, so it was with a update they did this year is my guess.
  1. 11.08.2020 08:08:55
  2. # 9
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Hello,

No solution yet. CL doesnt seem to find any solution yet. They Just asks us to try different things each time?
We didnt have this issue last year, so it was with a update they did this year is my guess.

Hello Morten,
Could you please re-open your ticket if the problem has not been resolved and our experts will help you.
Thank you
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.