php.ini max upload error
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. dave kemp
  2. Tuesday, 12 May 2020
  3.  Subscribe via email
default php.ini for php7.0

Have a customer who cannot upload a Wordpress plugin

error is


The uploaded file exceeds the upload_max_filesize directive in php.ini.


I have tried everywhere and cannot get the upload file size fixed so I guess im looking in the wrong place

The customers cpanel account has php uploads set to 1G in php selector but this is being over ridden somewhere

Is there somewhere can set a default for this in all php settings 5.6,7.7.1,7.2,7.3 etc ?

I have edited /opt/alt/php70/etc/php.ini and that doesn't help either

All CLUES would be greatly appreciated

CentOS7 Cpanel 86.x CL7.x
Rate this post:
  1. 13.05.2020 10:05:43
  2. # 1
Sergey Khristich Accepted Answer
Posts: 338
Joined: 20.05.2019
0
Votes
Undo
Hello Dave,
Thank you for reaching out! To help you with this question we need a little bit more information, could you please provide us the PHPinfo?
Thank you.
Marketing Manager
  1. 13.05.2020 13:05:13
  2. # 2
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
Interesting - it shows php7.3 being used - yet the customers cpanel php selector is 5.6, just changed it to 7.3 and still the same error, changed to 7.0 and back to 5.6 - all give same error

php ini file as per 7.3 phpinfo was edited to max upload 1024M - still getting the max upload size error

php ini 7.3 contains



;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 1024M


  1. 13.05.2020 13:05:14
  2. # 3
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
Looking at the php - its Easy apache so perhaps thats why the php selector for CL isn't working - Hmmmm I did turn off the multi php editor for EA4 so It would just use CL multi php - thoughts welcome
  1. 13.05.2020 15:05:23
  2. # 4
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
For the time being I have edited ea-php 7.3 and have the site uploading in Wordpress - no errors any more (had to also re-enable multi php in feature manager) - however id like to get to the bottom of why CL Multi php isn't working......
  1. 13.05.2020 16:05:16
  2. # 5
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
Ok after more delving, seems to be a conflict between ea4 php and CL php selector. CL one is not working, in multi php if I select any alt-php version I get red cpanel error boxes and the php won't change from any ea version.
  1. 13.05.2020 17:05:11
  2. # 6
Sergey Khristich Accepted Answer
Posts: 338
Joined: 20.05.2019
0
Votes
Undo
Hello Dave,
Can you open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new so we can take a closer look at your system? You can post the ticket number here and we'll link this thread to it.
Thank you.
Marketing Manager
  1. 13.05.2020 17:05:49
  2. # 7
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
Ticket #87610
  1. 13.05.2020 17:05:18
  2. # 8
Sergey Khristich Accepted Answer
Posts: 338
Joined: 20.05.2019
0
Votes
Undo
Ticket #87610

Thank you, our specialists will answer you on the ticket as quickly as possible.
Marketing Manager
  1. 13.05.2020 20:05:59
  2. # 9
dave kemp Accepted Answer
Posts: 7
Joined: 24.04.2020
0
Votes
Undo
Just a quick follow up

Thankyou to GREAT SUPPORT and very quick and knowledgeable replies from

Vitaly Nemykin (CloudLinux)

and

Daniil Ivanov (CloudLinux)

To cut a long story short - I hadn't disabled php-fpm on most accounts or globally and php version was set to 7.3 on all accounts and not inherit......

Changing that fixed all the problems

Many thanks chaps
  1. 14.05.2020 09:05:51
  2. # 10
Sergey Khristich Accepted Answer
Posts: 338
Joined: 20.05.2019
0
Votes
Undo
Hello Dave,
Happy to hear it and thanks for following up!
If you have any other questions, feel free to ask here.
Thank you for contacting us.
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.