PHP Extensions
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Mark Sheppard
  2. Thursday, 17 October 2019
  3.  Subscribe via email
Hi Everyone,
Is there a way i can install all php extensions and activate the on all versions of PHP? I am constantly getting issues telling me certain extensions are not installed even though it says on my side it is!

Thanks

Rockyuk
Rate this post:
  1. 17.10.2019 12:10:55
  2. # 1
Johannes Accepted Answer
Posts: 2
Joined: 23.06.2019
0
Votes
Undo
Dont do this! Never ever! Yes you can, but its complete BS, you make the server slower, you have more attack surfaces, and more work to hold the system updated (and more reboots are more downtimes), in short - you are begging for troubles. Only install the needed modules. Do your lessons, learn which you need.
  1. 17.10.2019 13:10:07
  2. # 2
Sergey Khristich Accepted Answer
Posts: 136
Joined: 20.05.2019
0
Votes
Undo
Hello Mark! Thank you for reaching out!
Johannes is right. Thanks, Johannes. As for the installation, you can install alt-php like this: yum groupinstall alt-php. More details here https://docs.cloudlinux.com/cloudlinux_os_components/#installation-and-update-4.
If you require any further information, let me know.
Marketing Manager
  1. 17.10.2019 13:10:12
  2. # 3
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
0
Votes
Undo
Hi Sergey,
I seem to always have this issue with CloudLinux it tells me the extensions are enable but when doing upgrades or script installs it tells me certain extensions are missing!

I am upgrading a script within Softaculous

Then gives me this error

The following errors were found :

Required PHP extension not found : json
Required PHP extension not found : PDO
Required PHP extension not found : mbstring

Which they are all enabled.

Thanks

Rockyuk
  1. 17.10.2019 17:10:30
  2. # 4
Sergey Khristich Accepted Answer
Posts: 136
Joined: 20.05.2019
0
Votes
Undo
Hi Mark, please specify, are you using alt-php or ea-php?
If you use alt-php then check rpm -qa|grep alt-phpXX-mbstring and for ea-php respectively.
Or if you can then post phpinfo and we will check. Thanks.
Marketing Manager
  1. 17.10.2019 18:10:48
  2. # 5
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
0
Votes
Undo

[[email protected] ~]# rpm -qa|grep alt-php71-mbstring
alt-php71-mbstring-7.1.32-3.1.el6.x86_64
[[email protected] ~]# rpm -qa|grep alt-php72-mbstring
alt-php72-mbstring-7.2.23-2.el6.x86_64
[[email protected] ~]# rpm -qa|grep alt-php73-mbstring
alt-php73-mbstring-7.3.10-2.el6.x86_64
  1. 17.10.2019 18:10:40
  2. # 6
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
0
Votes
Undo
[[email protected] ~]# cagefsctl --sanity-check
Check cagefs mount points exists:
OK: No missing mount points found

Check cagefs users.enabled is directory:
OK: /etc/cagefs/users.enabled is fine

Check cagefs users.disabled is directory:
OK: /etc/cagefs/users.disabled is fine

Check cagefs disable.etcfs exists:
OK: /etc/cagefs/http://etc.safe/disable.etcfs exists

Check cagefs users can enter cagefs:
OK: Several tested users really can enter cagefs

Check cagefs proxy commands configs are parsable:
OK: Syntax looks fine. Files are parsable

Check cagefs virt.mp files syntax:
SKIPPED: No virt.mp files found

Check MultiPHP system default php version:
FAILED: MultiPHP system default PHP version is alt-php. PHP Selector does not work and should be disabled!
  1. 18.10.2019 08:10:25
  2. # 7
Sergey Khristich Accepted Answer
Posts: 136
Joined: 20.05.2019
0
Votes
Undo
Hello Mark! Thanks for the information provided.
"FAILED: MultiPHP system default PHP version is alt-php. PHP Selector does not work and should be disabled!". This Error indicates that you have selected alt-php in MultiPHP Manager as System PHP Version and PHP Selector will NOT work in this case.
Here you can read in more detail: https://docs.cloudlinux.com/cloudlinux_os_components/#prerequisites
If you want to select alt-php as default, you can do this in LVE Manger> Selector> Default php version and select alt-php there.
If you have any other questions, feel free to ask here.
Thank you for contacting us.
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.