Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Chris
  2. Wednesday, August 09, 2017
  3.  Subscribe via email
Can't modify an account in WHM without entering individual settings for LVE limits. WHM 64.0 (build 36)

Today I went to change a domain on an account in WHM by using the "Modify Account" option. I changed the domain name and submitted the form but I received the following error..

Hook denied modification of account: Invalid value for IOPS

I left all the LVE options empty as always - but now it seems if these fields are left blank during the modify of account, the changes are not accepted.

I don't think anyone wants to manually enter these settings every time they modify an account.
Rate this post:
  1. 09.08.2017 09:08:57
  2. # 1
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
On a different server I go to Modify Account and there are no LVE settings at all - yet the package options are the same and the LVE manager settings are identical.
  1. 09.08.2017 11:08:39
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
We would like to review this situation, please create support ticket with us and provide steps to reproduce the issue. Something must be configured wrong.
  1. 09.08.2017 14:08:36
  2. # 3
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
There have been no configuration changes at the server. It's not a config issue but I think it's caused by a change in the way your software works with the packages.

If I edit the package in WHM, the LVE settings all say DEFAULT as they were previously - but If I simply save the package - those fields are now populated with the actual figures from LVE manager. This is the first time that has happened. As mentioned, before each field was populated with the word DEFAULT and that was the way until now.

So I'm sure at some point there has been a change in this behaviour - but it only is updated once the package has been re-saved.

Once this has been done, I can now modify an account and it adds the LVE limits correctly.
  1. 05.09.2017 23:09:40
  2. # 4
Louis Accepted Answer
Posts: 0
Joined: 16.01.2018
0
Votes
Undo
Seems this has started happening on one of our servers recently as well.

If you populate all the fields with DEFAULT, it works and saves the account.

Is this a bug introduced by a recent update?
  1. 09.09.2017 22:09:23
  2. # 5
muhammad Accepted Answer
Posts: 0
Joined: 16.01.2018
0
Votes
Undo
We have the same problem
  1. 12.09.2017 10:09:37
  2. # 6
rguez Accepted Answer
Same issue here.
  1. 13.09.2017 17:09:56
  2. # 7
Vladimir Accepted Answer
Posts: 45
Joined: 04.07.2017
0
Votes
Undo
Hello,

Please submit a ticket to https://cloudlinux.zendesk.com, our techs will check the issue in place.
  1. 26.11.2017 13:11:14
  2. # 8
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
Something has changed again. The LVE limits no longer appear in the packages. I don't see this as a problem - but I'd like to copy the limits to new servers without having to individually set them all on every server.

Can you tell me what file the limits are stored in? They are not held within the package files in /var/cpanel/packages
  1. 27.11.2017 13:11:20
  2. # 9
Igor Ghertesco Accepted Answer
Posts: 76
Joined: 07.08.2015
0
Votes
Undo
Chris,

We need to have more information about your current setup (packages versions, panel version, etc), so please submit a ticket to https://cloudlinux.zendesk.com/hc/en-us/requests/new
  1. 27.11.2017 17:11:19
  2. # 10
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
You're saying that the package LVE limits are stored in different locations depending on the cpanel version?

How many different places can this info be stored?

Why can't you reveal this information? This isn't specific to my environment.

Why isn't it documented?
  1. 27.11.2017 19:11:55
  2. # 11
Igor Ghertesco Accepted Answer
Posts: 76
Joined: 07.08.2015
0
Votes
Undo
Chris,

Packages limits are stored in /var/cpanel/packages/package_name, for example:

....
MAX_DEFER_FAIL_PERCENTAGE=unlimited
MAX_EMAIL_PER_HOUR=unlimited
QUOTA=unlimited
_PACKAGE_EXTENSIONS=lve
lve_ncpu=DEFAULT
lve_cpu=50%
lve_io=1026
lve_mem=DEFAULT
lve_pmem=DEFAULT


I've mentioned panel version because cPanel constantly improves their API and work with packages extensions (you can refer to this blog post)
  1. 27.11.2017 20:11:56
  2. # 12
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
No. The limits are not saved to those files. I changed the LVE package limits - checked the files, the limits are not included in the package files.

Under the cpanel package settings it says...
_PACKAGE_EXTENSIONS=

But there are no LVE limits defined here.

Can you tell me when this is saved? Does it happen when the package limits are changed? Or does some other process update it? Should I wait until a cron job runs?

How can I force it to update these files?

These are new servers - running CL7 and cpanel 68.0.16 Do not ask me to raise a support ticket. There is nothing unique about my environment - these are standard install of CL and cpanel. I'm sure others would benefit from this discussion. I can't be the only one with this problem.
  1. 28.11.2017 15:11:50
  2. # 13
Igor Ghertesco Accepted Answer
Posts: 76
Joined: 07.08.2015
0
Votes
Undo
Chris,

If lve extension is not enabled, the package limits values won't be saved as well.

There is one cron task which syncs the packages limits with /etc/container/ve.cfg file (default, custom and packages limits are stored in this file). The task is located in /etc/cron.d/lvemanager-cron file (/usr/bin/cl-syncpkgs is called every 5 minutes)
  1. 28.11.2017 16:11:11
  2. # 14
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
Can you please clarify what you mean by "lve extension" ?

Ok so I've seen this...

https://docs.cloudlinux.com/index.html?cpanel_lve_extension.html

The screenshot shows that when you create a package, there SHOULD be a tick box at the bottom with the title Extensions, then LVE.

This doesn't appear on any of my servers. All I've done is install CENTOS 7 minimal - then run the cpanel installer which detects my CL license and converts the server to CL during the process.

Can you please tell me what I need to do in order to enable the LVE Extension?
This is vital to making sure the packages have the correct resources.

Also, I set up the package limits via LVE manager can you please tell me - will the limits still hold - even though they are not "tied" into the WHM packages via the LVE extension?
  1. 28.11.2017 18:11:53
  2. # 15
Igor Ghertesco Accepted Answer
Posts: 76
Joined: 07.08.2015
0
Votes
Undo
Chris,

LVE extension for a package does appear in our test environment. So please submit a ticket to our support team, we will check the issue in place.
  1. 28.11.2017 20:11:47
  2. # 16
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
I don't give third party access to my servers. I need you to answer this question...

Will the package limits still work? I set them in the LVE manager.

I don't care so much if they are not in the packages in WHM as long as the limits actually work.
  1. 29.11.2017 09:11:58
  2. # 17
Chris Accepted Answer
Posts: 18
Joined: 31.03.2017
0
Votes
Undo
You guys are not good at supporting your product.

So after some digging around I worked out that under /var/cpanel/packages is a subdirectory "extensions" and the LVE extension binaries are located here normally.

On new servers, these binaries are not included. You'll need to work out why this doesn't happen. I have built four new servers this week with cpanel on CL7 and none of them have these extensions.

I copied the extensions from another server into that folder and it is now working correctly. This is all I needed to do. You could easily have explained that to me.

I think you have a good product. I like Cloudlinux - but you are not good at providing support. This was a simple fix that you could easily have told me about - but I had to dig around and find it for myself.
  1. 29.11.2017 13:11:12
  2. # 18
Igor Ghertesco Accepted Answer
Posts: 76
Joined: 07.08.2015
0
Votes
Undo
Chris,

Thank you for your feedback, but usually we provide support via ticket system (zendesk). We are collecting basic info about your setup via cldoctor script, and then trying to reproduce the issue in our test servers, and requesting the access to your environment only if the issue can not be reproduced.

Please do not hesitate to contact our support if you face any issue.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Remove Upload Files (Maximum File Size: 2 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.