error installing new version of php in EasyApache 4
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Fernando
  2. Monday, 20 April 2020
  3.  Subscribe via email
I have a small server running cloudlinux 7.4, which has WHM installed to manage it, in addition to EasyApache 4 so I need to install a new version of php for my server in this case php73, when installing I get this error in the panel:

Update Error:


Error: Package: 1:ea-libcurl-7.69.1-2.el7.cloudlinux.x86_64 (cl-ea4)
Requires: libssh2 >= 1.8.0
Installed: libssh2-1.4.3-10.el7_2.1.x86_64 (@updates)
libssh2 = 1.4.3-10.el7_2.1
Error: Package: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 (cl-ea4)
Requires: yajl
Error: Package: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 (cl-ea4)
Requires: libyajl.so.2()(64bit)
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2020-04-19_14:52:52-1


So why is this error, how can I fix it?
Rate this post:
  1. 20.04.2020 16:04:55
  2. # 1
Sergey Khristich Accepted Answer
Posts: 430
Joined: 20.05.2019
0
Votes
Undo
Hello Fernando,
Thank you for reaching out! It looks like you have CentOS repos enabled that should be disabled. This command should help you in this matter:

# mv /etc/cl-convert-saved/CentOS-* /etc/yum.repos.d/

If this does not solve the problem could you please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new and technical experts will help you asap. Thank you for contacting us.
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.