Error: 'directory' when installing python app
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Alexis
  2. Thursday, 04 January 2018
  3.  Subscribe via email

One of our customer is unable to create a new Python app with the CloudLinux Python Selector.

It just returns a message, in a red box with "directory" and nothing else. I checked the error log (every one I can think of) but I don't find anything related to python/cloudlinux.

I straced the cPanel main process to watch what's going on, I managed to intercept the selectorctl command used, it's like this :

# The command I intercepted
/usr/bin/selectorctl --interpreter=python --version=3.5 --user=xxxxxxx --print-summary --json --create-webapp test /

# The one I tried with --verbose and without --json
/usr/bin/selectorctl --verbose --interpreter=python --version=3.5 --user=xxxxxxx --print-summary --create-webapp test /

It just returns : ERROR:'directory'

I straced the cli too but I can't see anything important, it checked all the .htaccess of the account. I tried removing cache files too (like .cl.selector/htaccess_cache) but it does not change anything.

I check the file permission (chmod 755 for directory and chmod 644 for files), I enforced it, but is doesn't change anything either.

Any ideas ?

Thanks in advance,
Kind regards,
Attachments (1)
Rate this post:
  1. 04.01.2018 13:01:55
  2. # 1
Igor Ghertesco Accepted Answer
Posts: 153
Joined: 07.08.2015

Please submit a ticket to, our techs will take a closer look
  • Page :
  • 1

There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.