Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Chris
  2. Thursday, October 05, 2017
  3.  Subscribe via email
Hi I just converted a server from EA3 to EA4 and now cpanel has written the following to all my users htaccess files...

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php56” package as the default “PHP” programming language.
<IfModule mime_module>
AddType application/x-httpd-ea-php56___lsphp .php .php5 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

All users were previously using PHP Selector.
I only have one native version installed ea-php56 which is the default version on the server.

Your documentation says that if I select the default version for the users in WHM's MultiPHP Manager, the CloudLinux PHP Selector will take control of the version. But this doesn't appear to be happening. From what I can tell - selecting this version has forced the cpanel PHP manager to add the above handler to all my users htaccess files.

How can I fix this?
Rate this post:
  1. 10.10.2017 21:10:51
  2. # 1
Ryan Accepted Answer
Posts: 22
Joined: 18.10.2016
0
Votes
Undo
It looks like something in WHM's MultiPHP Manage might not be setup right. Make sure each account is set to use the WHM system default php version. I have all my accounts set to "Inherit"
  1. 12.10.2017 11:10:05
  2. # 2
Igor Ghertesco Accepted Answer
Posts: 138
Joined: 07.08.2015
0
Votes
Undo
Hello,

Ryan is right, please make sure that all accounts are set to "inherit".

If you still face any issue, please feel free to submit a ticket to our helpdesk: https:/cloudlinux.zendesk.com
  1. 16.10.2017 09:10:43
  2. # 3
Sebastian Accepted Answer
Posts: 0
Joined: 18.12.2018
0
Votes
Undo
Today I had the same problem.
Without changing anything he added:

# php -- BEGIN cPanel-generated handler, do not edit
# Legen Sie das Paket „ea-php56“ als Standardprogrammiersprache „PHP“ fest.
#<IfModule mime_module>
AddType application/x-httpd-ea-php56 .php .php5 .phtml
#</IfModule>
# php -- END cPanel-generated handler, do not edit

to one project to the main .htaccess file.

All accounts are on "inherit".

So I commit it out.

But when will it appear next?

It is strange. :-(
  1. 16.10.2017 14:10:31
  2. # 4
Ryan Accepted Answer
Posts: 22
Joined: 18.10.2016
0
Votes
Undo
It definitely looks like multiPHP seems like it feels it's in charge. One thing you can try is to toggle an account away from inherit and back to see if that fixes it. I had a situation once where I needed to do that.

Other than that, be sure your accounts are setup right with selectorctl http://docs.cloudlinux.com/index.html?selectorctl.html
  1. 20.10.2017 11:10:21
  2. # 5
Vladimir Accepted Answer
Posts: 88
Joined: 04.07.2017
0
Votes
Undo
Hello, Sebastian.

Please submit a ticket to https://cloudlinux.zendesk.com, our techs will check the issue in place.
  1. 22.11.2017 19:11:21
  2. # 6
Michael Accepted Answer
Posts: 0
Joined: 18.12.2018
0
Votes
Undo
We have the same issue here. It could be fully resolved with Ryans suggestion of setting the useraccounts to inherit (and the system default php version to whatever you need).
It´s just strange that these changes were made out of nowhere, so we had no chance to be prepared.
This seems to be a CPanel issue with Multi-PHP, not Cloudlinux.
  1. 28.11.2017 06:11:25
  2. # 7
Vladimir Accepted Answer
Posts: 88
Joined: 04.07.2017
0
Votes
Undo
Hello,

Could you please specify, what was done before this issue appears?
So far we were not able to reproduce this bug on our test server.
  1. 28.11.2017 08:11:39
  2. # 8
Michael Accepted Answer
Posts: 0
Joined: 18.12.2018
0
Votes
Undo
I really have no clue. I was installing engintron nginx caching before that happens, but had to disable it due to unforseeable issues caused by this type of setup. But I can`t imagine that this can cause such errors.
.
btw, it has not been resolved fully by the above method, as part of the users had their PHP version been "reset" in PHP Selector to PHP 4.4 with (no selectable extensions). After that, setting their version to 7.1 for example, does not set the default extensions as defined in LVE managers selector setup. But extensions could be selected/deselected manually and this seems to work.
  1. 28.11.2017 16:11:04
  2. # 9
Vladimir Accepted Answer
Posts: 88
Joined: 04.07.2017
0
Votes
Undo
It sounds really strange. If you still have users affected by this issue, please submit a support ticket:
https://cloudlinux.zendesk.com
We would like to check this problem in place.
  1. 28.11.2017 19:11:36
  2. # 10
Michael Accepted Answer
Posts: 0
Joined: 18.12.2018
0
Votes
Undo
Not anymore, we forcefully set all affected users to php7.1 with a standard set of extensions by selectorctl. (Just to reduce the amount of new support tickets)
There is still one user left who looks good, but php files are served as cleartext (source). There is appearently no reason for that, so if I can´t find the cause, I come back with a ticket :-)
  1. 29.11.2017 09:11:03
  2. # 11
Vladimir Accepted Answer
Posts: 88
Joined: 04.07.2017
0
Votes
Undo
Yes, sure.
Do not hesitate to contact us if you have any further questions or concerns.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Remove Upload Files (Maximum File Size: 2 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.