ea-apache24-mod-alt-passenger conflicts with 1:ea-ruby24-mod_passenger-5.3.7-3.el7.cloudlinux.1.x86_64
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Alex
  2. Thursday, 23 January 2020
  3.  Subscribe via email
Hello guys,
When trying to install apache module for LVE manager this thing happens:

yum install -y ea-apache24-mod-alt-passenger
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
* EA4: 93.115.203.100
* cpanel-addons-production-feed: 93.115.203.100
* cpanel-plugins: 93.115.203.100
* cloudlinux-x86_64-server-7: cl-mirror.fra1.stablepoint.com
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24-mod-alt-passenger.x86_64 0:5.3.7-9.el7.cloudlinux will be installed
--> Processing Dependency: libcurl-devel for package: ea-apache24-mod-alt-passenger-5.3.7-9.el7.cloudlinux.x86_64
--> Processing Dependency: alt-ruby21-devel for package: ea-apache24-mod-alt-passenger-5.3.7-9.el7.cloudlinux.x86_64
--> Processing Dependency: alt-ruby21-rubygem-rake for package: ea-apache24-mod-alt-passenger-5.3.7-9.el7.cloudlinux.x86_64
--> Running transaction check
---> Package alt-ruby21-devel.x86_64 0:2.1.10-22.1.el7 will be installed
---> Package alt-ruby21-rubygem-rake.x86_64 0:10.1.0-22.1.el7 will be installed
---> Package libcurl-devel.x86_64 0:7.29.0-54.el7_7.1 will be installed
cloudlinux-x86_64-server-7/filelists | 88 MB 00:00:01
--> Processing Conflict: ea-apache24-mod-alt-passenger-5.3.7-9.el7.cloudlinux.x86_64 conflicts ea-ruby24-mod_passenger
--> Finished Dependency Resolution
Error: ea-apache24-mod-alt-passenger conflicts with 1:ea-ruby24-mod_passenger-5.3.7-3.el7.cloudlinux.1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Do you have any insight as to why this is happening and how to correct it ?
Rate this post:
  1. 23.01.2020 09:01:43
  2. # 1
Sergey Khristich Accepted Answer
Posts: 493
Joined: 20.05.2019
0
Votes
Undo
Hello Alex,
Thank you for reaching out! According to the information that you provided, it can be argued that one of these CL, the other cPanel. Therefore, a conflict occurs. You need to choose which passenger and implementation of the ruby you will use and then install and remove the other.
Please let us know if you have any questions. Thanks in advance!
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Alex
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.