CloudLinux - CloudLinux Blog - mod_lsapi PRO updated
RSS

mod_lsapi PRO updated

mod_lsapi1

New updated mod_lsapi PRO packages for CloudLinux 6 and 7 as well as for Apache 2.4 (CloudLinux 6 and CloudLinux 7) and EasyApache 4 (CloudLinux 6 and 7) are now available for download from our production repository.

Release notes

In this release, we added a new option lsapi_use_req_hostname (MODLS-621):

  • Syntax: lsapi_use_req_hostname On/Off
  • Default: lsapi_use_req_hostname Off
  • Context: httpd.conf, virtualhosts

Description

By default, we are using hostname from the server_rec structure (off) it means that mod_lsapi takes hostname from the VirtualHost section of the configuration file. Using hostname from the request_rec structure (On) means that mod_lsapi takes hostname from the HOST section of the request. It could be useful for those who use dynamically generated configs for virtual hosts for example with mod_lua.

Changelog:

liblsapi-1.1-37

mod_lsapi-1.1-37

ea-apache24-mod_lsapi-1.1-37

httpd24-mod_lsapi-1.1-37

  • MODLS-616: ensure existence of directory for lsapi sockets in /var/run;
  • MODLS-621: add a configuration option (lsapi_use_req_hostname) that controls how virtualhost name is picked;
  • AAP-253: spec and cmake files redesigned for new httpd24 build.

To install

To install, follow the instructions here

To update:

cPanel & RPM Based:

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ yum update mod_lsapi
$ service httpd restart 

DirectAdmin: 

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ cd /usr/local/directadmin/custombuild
$ ./build update
$ ./build mod_lsapi 

EasyApache 4: 

$ yum clean all
$ yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi
$ service httpd restart 

httpd24 for CloudLinux 6 and CloudLinux 7: 

$ yum update liblsapi liblsapi-devel
$ yum update httpd24-mod_lsapi 
Beta: Imunify360 4.0.4 released
Beta: MariaDB for MySQL Governor updated
 

Comments 2

Guest - Ivan Levente on Thursday, 21 March 2019 05:14

What's mod_lsapi PRO? Is that something new? I have mod_lsapi installed since several years ago. Is it the same?
Thanks.

What's mod_lsapi PRO? Is that something new? I have mod_lsapi installed since several years ago. Is it the same? Thanks.
Inessa Atmachian on Thursday, 21 March 2019 18:06

Hi Ivan,

The former mod_lsapi is now called mod_lsapi PRO. So, no worries at all, you have the right mod_lsapi (PRO) installed.

Hi Ivan, The former mod_lsapi is now called mod_lsapi PRO. So, no worries at all, you have the right mod_lsapi (PRO) installed.
Already Registered? Login Here
Guest
Saturday, 29 February 2020

Captcha Image