CloudLinux Blog - mod_lsapi updated

mod_lsapi updated

mod_lsapi updated

The new updated mod_lsapi packages for CloudLinux 6 and 7 as well as for Apache 2.4 (CloudLinux 6 and 7) and EasyApache 4 (CloudLinux 6 and 7) are available for download from our production repository.

Changelog:

mod_lsapi 1.1-21

ea-apache24-mod_lsapi 1.1-21

httpd24-mod_lsapi 1.1-21

  • MODLS-452: fixed destroying of starter mutex on worker and event MPMs;
  • MODLS-457: added PWD var into safe environment as cwd of backend process;
  • MODLS-464: fixed max size of response header package;
  • MODLS-463: added application/x-httpd-ea-php72___lsphp /opt/cpanel/ea-php72/root/usr/bin/lsphp and application/x-httpd-ea-php72-lsphp /opt/cpanel/ea-php72/root/usr/bin/lsphp;
  • MODLS-460: added ability to set lsapi_backend_children manually.

To update:

cPanel & RPM Based

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ yum update mod_lsapi
$ service httpd restart

DirectAdmin

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ cd /usr/local/directadmin/custombuild
$ ./build update
$ ./build mod_lsapi

To install, follow the instructions on the link.

EasyApache 4

To update:

$ yum clean all
$ yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi
$ service httpd restart

To install:

$ yum clean all
$ yum update liblsapi liblsapi-devel

Read http://docs.cloudlinux.com/index.html?cpanel_easyapache_4.html

Go to MultiPHP Manager and enable mod_lsapi on your domains through lsapi handler.

Find more about MultiPHP Manager and mod_lsapi on the link.

http24 for CloudLinux 6 and CloudLinux 7

For installation/update run:

$ yum update liblsapi liblsapi-devel
$ yum install httpd24-mod_lsapi
Alt-mod-passenger updated
Alt-PHP updated
 

By accepting you will be accessing a service provided by a third-party external to https://www.cloudlinux.com/