CloudLinux - CloudLinux Blog - Beta: mod_lsapi PRO updated
RSS

By accepting you will be accessing a service provided by a third-party external to https://www.cloudlinux.com/

Beta: mod_lsapi PRO updated

mod_lsapi1

New updated mod_lsapi PRO packages for CloudLinux 6 and 7 as well as for Apache 2.4 (CloudLinux 6 and CloudLinux 7) and EasyApache 4 (CloudLinux 6 and 7) are now available for download from our updates-testing repository.

Changelog:

liblsapi-1.1-38

mod_lsapi-1.1-38

ea-apache24-mod_lsapi-1.1-38

httpd24-mod_lsapi-1.1-38

  • MODLS-577: log changed for errors produced by http filter;
  • AAP-243: Sentry: create a mechanism to save errors from mod_lsapi;
  • MODLS-644: added ea-php73 lsapi handler;
  • added troubleshooting link into the log for the rejected request.

Release notes

In order to improve the quality of the module, we want to know what problems the user most often encounters when using mod_lsapi. Therefore, in this release we added a new lsapi_sentry option (AAP-243):

  • Syntax: lsapi_sentry On/Off
  • Default: lsapi_sentry On
  • Context: httpd.conf

Description

When this option is enabled, errors that occur in the operation of the mod_lsapi will be sent to the remote sentry server. You can see the error messages that were sent to the sentry server in the directory /var/log/mod_lsapi. If you do not want to send an error notifications from your server, you can disable this directive in lsapi.conf.

To install

To install mod_lsapi PRO, follow our docs for the instructions here.

To update from Beta

For EasyApache 4:

# yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi --enablerepo=cl-ea4-testing --enablerepo=cloudlinux-updates-testing
# service httpd restart

For EasyApache 3 (note EA3 EoL), Plesk and no control panel RPM-based platforms

# yum update mod_lsapi liblsapi liblsapi-devel --enablerepo=cloudlinux-updates-testing
# service httpd restart

For DirectAdmin:

# yum update liblsapi liblsapi-devel --enablerepo=cloudlinux-updates-testing
# cd /usr/local/directadmin/custombuild
# ./build set cloudlinux_beta yes
# ./build update
# ./build mod_lsapi

For httpd24:

# yum update httpd24-mod_lsapi liblsapi liblsapi-devel --enablerepo=cloudlinux-updates-testing
Beta: MariaDB for MySQL Governor updated
Beta: Imunify360 4.0.6 released
 

Comments 2

Guest - Argjend on Wednesday, 27 March 2019 20:07

Hi,

I have encountered a problem during updating.

[email protected] [~]# yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi --enablerepo=cl-ea4-testing --enablerepo=cloudlinux-updates-testing --skip-broken
Loaded plugins: fastestmirror, protectbase, rhnplugin, universal-hooks
Setting up Update Process
Loading mirror speeds from cached hostfile
* cpanel-addons-production-feed: 185.69.232.245
* cpanel-plugins: 185.69.232.245
* cloudlinux-x86_64-server-6: de-proxy.cloudlinux.com
6170 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24-mod_lsapi.x86_64 1:1.1-37.el6.cloudlinux will be updated
---> Package ea-apache24-mod_lsapi.x86_64 1:1.1-38.el6.cloudlinux will be an update
--> Processing Dependency: liblsapi = 1:1.1-38.el6.cloudlinux for package: 1:ea-apache24-mod_lsapi-1.1-38.el6.cloudlinux.x86_64
cl-ea4-testing/filelists_db | 1.8 MB 00:01

Packages skipped because of dependency problems:
1:ea-apache24-mod_lsapi-1.1-38.el6.cloudlinux.x86_64 from cl-ea4-testing

Does any solution, please?

Hi, I have encountered a problem during updating. [email protected] [~]# yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi --enablerepo=cl-ea4-testing --enablerepo=cloudlinux-updates-testing --skip-broken Loaded plugins: fastestmirror, protectbase, rhnplugin, universal-hooks Setting up Update Process Loading mirror speeds from cached hostfile * cpanel-addons-production-feed: 185.69.232.245 * cpanel-plugins: 185.69.232.245 * cloudlinux-x86_64-server-6: de-proxy.cloudlinux.com 6170 packages excluded due to repository protections Resolving Dependencies --> Running transaction check ---> Package ea-apache24-mod_lsapi.x86_64 1:1.1-37.el6.cloudlinux will be updated ---> Package ea-apache24-mod_lsapi.x86_64 1:1.1-38.el6.cloudlinux will be an update --> Processing Dependency: liblsapi = 1:1.1-38.el6.cloudlinux for package: 1:ea-apache24-mod_lsapi-1.1-38.el6.cloudlinux.x86_64 cl-ea4-testing/filelists_db | 1.8 MB 00:01 Packages skipped because of dependency problems: 1:ea-apache24-mod_lsapi-1.1-38.el6.cloudlinux.x86_64 from cl-ea4-testing Does any solution, please?
Inessa Atmachian on Thursday, 28 March 2019 08:22

Hi Argjend,

It looks like your protectbase plugin is on. Because of 6170 packages excluded due to repository protections. Try running the same command with the `--disableplugin=protectbase` key.

Hi Argjend, It looks like your protectbase plugin is on. Because of 6170 packages excluded due to repository protections. Try running the same command with the `--disableplugin=protectbase` key.
Already Registered? Login Here
Guest
Thursday, 16 July 2020

Captcha Image