CloudLinux OS Blog

PHP for EasyApache 4 updated

PHP for EasyApache 4 updated

New updated ea-php packages are available for download from our production repository.

Changelog:

ea-php51-5.1.6-16.cloudlinux

  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx.

ea-php52-5.2.17-19.cloudlinux

ea-php53-5.3.29-21.cloudlinux

ea-php54-5.4.45-46.cloudlinux

ea-php55-5.5.38-29.cloudlinux

  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx;
  • (phar) 74782: reflected XSS in .phar 404 page.

ea-php56-5.6.33-1.cloudlinux

  • updated to 5.6.33;
  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx;
  • (phar) 74782: reflected XSS in .phar 404 page.

ea-php70-7.0.27-1.cloudlinux

  • updated to 7.0.27;
  • (cli server) 60471: random "Invalid request (unexpected EOF)" using a router script;
  • (core) 75384: PHP seems incompatible with OneDrive files on demand;
  • (core) 75573: segmentation fault in 7.1.12 and 7.0.26;
  • (fpm) 64938: libxml_disable_entity_loader setting is shared between requests;
  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx;
  • (opcache) 75579: interned strings buffer overflow may cause crash;
  • (pcre) 74183: preg_last_error not returning error code after error;
  • (phar) 74782: reflected XSS in .phar 404 page;
  • (standard) 75535: inappropriately parsing HTTP response leads to PHP segment fault;
  • (standard) 75409: accept EFAULT in addition to ENOSYS as indicator that getrandom() is missing;
  • (zip) 75540: segfault with libzip 1.3.1.

ea-php71-7.1.13-1.cloudlinux

  • updated to 7.1.13;
  • (core) 75573: segmentation fault in 7.1.12 and 7.0.26;
  • (core) 75384: PHP seems incompatible with OneDrive files on demand;
  • (core) 74862: unable to clone instance when private __clone defined;
  • (core) 75074: php-process crash when is_file() is used with strings longer 260 chars;
  • (cli server) 60471: random "Invalid request (unexpected EOF)" using a router script;
  • (cli server) 73830: directory does not exist;
  • (fpm) 64938: libxml_disable_entity_loader setting is shared between requests;
  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx;
  • (opcache) 75608: "Narrowing occurred during type inference" error;
  • (opcache) 75579: interned strings buffer overflow may cause crash;
  • (opcache) 75570: "Narrowing occurred during type inference" error;
  • (pcre) 74183: preg_last_error not returning error code after error;
  • (phar) 74782: remove file name from output to avoid XSS;
  • (standard) 75511: fread not free unused buffer;
  • (standard) 75514: mt_rand returns value outside [$min,$max]+ on 32-bit;
  • (standard) 75535: inappropriately parsing HTTP response leads to PHP segment fault;
  • (standard) 75409: accept EFAULT in addition to ENOSYS as indicator that getrandom() is missing;
  • (standard) 73124: php_ini_scanned_files() not reporting correctly;
  • (standard) 75574: putenv does not work properly if parameter contains non-ASCII unicode character;
  • (zip) 75540: segfault with libzip 1.3.1.

ea-php72-7.2.1-1.cloudlinux

  • updated to 7.2.1;
  • (core) 75573: segmentation fault in 7.1.12 and 7.0.26;
  • (core) 75384: PHP seems incompatible with OneDrive files on demand;
  • (core) 75525: Access Violation in vcruntime140.dll;
  • (core) 74862: unable to clone instance when private __clone defined;
  • (core) 75074: php-process crash when is_file() is used with strings longer 260 chars;
  • (cli server) 73830: directory does not exist;
  • (fpm) 64938: libxml_disable_entity_loader setting is shared between requests;
  • (gd) 75571: potential infinite loop in gdImageCreateFromGifCtx;
  • (opcache) 75608: "Narrowing occurred during type inference" error;
  • (opcache) 75579: interned strings buffer overflow may cause crash;
  • (opcache) 75570: "Narrowing occurred during type inference" error;
  • (opcache) 75556: invalid opcode 138/1/1;
  • (pcre) 74183: preg_last_error not returning error code after error;
  • (phar) 74782: remove file name from output to avoid XSS;
  • (standard) 75511: fread not free unused buffer;
  • (standard) 75514: mt_rand returns value outside [$min,$max]+ on 32-bit;
  • (standard) 75535: inappropriately parsing HTTP response leads to PHP segment fault;
  • (standard) 75409: accept EFAULT in addition to ENOSYS as indicator that getrandom() is missing;
  • (standard) 73124: php_ini_scanned_files() not reporting correctly;
  • (standard) 75574: putenv does not work properly if parameter contains non-ASCII unicode character;
  • (zip) 75540: segfault with libzip 1.3.1.

Update command:

yum update ea-php*

Topic: CloudLinux OS Blog , Tags: #PHP Selector, #PHP Selector, #easyapache4,

1299 people viewed this

Comments

 
No comments yet

Leave your comment

Guest, Wednesday, 16 January 2019

Captcha Image