CloudLinux OS Blog - PHP for EasyApache 4 updated
CloudLinux OS Blog

PHP for EasyApache 4 updated

PHP for EasyApache 4 updated

The new updated ea-php packages are available for download from our production repository.

Changelog:

ea-php70-7.0.23-1.cloudlinux

  • (core) 74947: Segfault in scanner on INF number;
  • (core) 74954: null deref and segfault in zend_generator_resume();
  • (core) 74725: html_errors=1 breaks unhandled exceptions;
  • (curl) 74125: Fixed finding CURL on systems with multiarch support;
  • (date) 75002: Null Pointer Dereference in timelib_time_clone;
  • (intl) 74993: Wrong reflection on some locale_* functions;
  • (mbstring) 71606: Segmentation fault mb_strcut with HTML-ENTITIES encoding;
  • (mbstring) 62934: mb_convert_kana() does not convert iteration marks;
  • (mbstring) 75001: Wrong reflection on mb_eregi_replace;
  • (mysqli) 74968: PHP crashes when calling mysqli_result::fetch_object with an abstract class;
  • (oci8): Expose oci_unregister_taf_callback();
  • (phar) 74991: include_path has a 4096 char limit in some cases;
  • (reflection) 74949: null pointer dereference in _function_string;
  • (session) 74833: SID constant created with wrong module number;
  • (simplexml) 74950: nullpointer deref in simplexml_element_getDocNamespaces;
  • (spl) 75049: spl_autoload_unregister can't handle spl_autoload_functions results;
  • (spl) 74669: Unserialize ArrayIterator broken;
  • (spl) 75015: Crash in recursive iterator destructors;
  • (standard) 75075: unpack with X* causes infinity loop;
  • (standard) 74103: heap-use-after-free when unserializing invalid array size;
  • (standard) 75054: A Denial of Service Vulnerability was found when performing deserialization;
  • (wddx) 73793: WDDX uses wrong decimal separator;
  • (xmlrpc) 74975: Incorrect xmlrpc serialization for classes with declared properties.

ea-php71-7.1.9-1.cloudlinux

  • (core) 74947: Segfault in scanner on INF number;
  • (core) 74954: null deref and segfault in zend_generator_resume();
  • (core) 74725: html_errors=1 breaks unhandled exceptions;
  • (core) 75063: Main CWD initialized with wrong codepage;
  • (curl) 74125: Fixed finding CURL on systems with multiarch support;
  • (date): 75002: (Null Pointer Dereference in timelib_time_clone);
  • (intl) 74993: Wrong reflection on some locale_* functions;
  • (mbstring) 71606: Segmentation fault mb_strcut with HTML-ENTITIES encoding;
  • (mbstring) 62934: mb_convert_kana() does not convert iteration marks;
  • (mbstring) 75001: Wrong reflection on mb_eregi_replace;
  • (mysqli) 74968: PHP crashes when calling mysqli_result::fetch_object with an abstract class;
  • (oci8): Expose oci_unregister_taf_callback();
  • (opcache) 74980: Narrowing occurred during type inference;
  • (phar) 74991: include_path has a 4096 char limit in some cases;
  • (reflection) 74949: null pointer dereference in _function_string;
  • (session) 74892: Url Rewriting (trans_sid) not working on urls that start with "#";
  • (session) 74833: SID constant created with wrong module number;
  • (simplexml) 74950: nullpointer deref in simplexml_element_getDocNamespaces;
  • (spl) 75049: spl_autoload_unregister can't handle spl_autoload_functions results;
  • (spl) 74669: Unserialize ArrayIterator broken;
  • (spl) 74977: Appending AppendIterator leads to segfault;
  • (spl) 75015: Crash in recursive iterator destructors;
  • (standard) 75075: unpack with X* causes infinity loop;
  • (standard) 74103: heap-use-after-free when unserializing invalid array size;
  • (standard) 75054: A Denial of Service Vulnerability was found when performing deserialization;
  • (wddx) 73793: WDDX uses wrong decimal separator;
  • (xmlrpc) 74975: Incorrect xmlrpc serialization for classes with declared properties.

ea-php53-5.3.29-16.cloudlinux

  • ALTPHP-364: added сorrect exit from LVE if the nproc limit is reached;
  • EA-6574: made permissions on FPM socket dir more secure.

ea-php54-5.4.45-40.cloudlinux

ea-php55-5.5.38-24.cloudlinux

ea-php56-5.6.31-3.cloudlinux

  • ALTPHP-364: added сorrect exit from LVE if the nproc limit is reached;
  • EA-6574: made permissions on FPM socket dir more secure;
  • EA-4197: made php.ini directives consistent with other versions.

To update run the command:

yum update ea-php*
Coming to Vegas? Don’t miss Igor Seletskiy’s sessi...
Beta: Alt-PHP updated
 

Comments 3

Guest - Jaime Eduardo Gomez on Friday, 08 September 2017 13:49

Hi !!

When will you publish the installation of Ioncube 10 for ea-php-7.1?

Thanks !

Hi !! When will you publish the installation of Ioncube 10 for ea-php-7.1? Thanks !
Mykola Naugolnyi on Friday, 08 September 2017 14:41

Hi Jaime,

Beta release is planned on Monday, September 11th.

Hi Jaime, Beta release is planned on Monday, September 11th.
Mykola Naugolnyi on Friday, 08 September 2017 14:40

Hi Jaime,

Beta release is planned on Monday, September 11th.

Hi Jaime, Beta release is planned on Monday, September 11th.
Already Registered? Login Here
Guest
Tuesday, 19 November 2019

Captcha Image