CloudLinux OS Blog - Enjoy our new client Python Selector—now in Beta
CloudLinux OS Blog

Featured 

Enjoy our new client Python Selector—now in Beta

Python-selector-beta3

I’m here again and I have some fresh news for you! Hold on guys, and take a look at our new client Python Selector—today, in beta, available for cPanel and DirectAdmin.

What’s new

  • Environment variables

    Now, you can configure the environment variables that are available in the application. You can set them when creating an application, or modify them later (don’t forget to restart the application). In the old Python Selector, you could configure them only with workarounds.

  • The ability to start/stop applications

    Now, you can not only restart your applications, but you can also start/stop them at any time (e.g. for debugging or maintenance). Previously, you could do that only with workarounds.

  • Config files UI management

    Now, you can configure a set of “config files” for your application and edit them directly from the UI. This avoids re-uploading files every time you need to change something temporarily (e.g. “Requirements” files or debug/logging mode etc.).

Sounds good, doesn’t it? But there's more to come.

Significant Changes

Instead of managing modules individually, as in the old Python Selector, you can now install all required modules for an application by specifying the proper requirements files and triggering an installation action either via the UI or the CLI.

Migration

All existing Python applications (created before the update of LVE Manager to version 5.0.1-1) will work the same as before. You do not need to migrate them unless you’d like to use the new features. We define these applications as “old applications“.

WARNING
There are some risks with the migration process and it can fail. To avoid any problems, and make it easier to solve any, only the user who created a particular application is allowed to start the migration process.

You do not need to migrate any new applications created after the update to LVE Manager 5.0.1-1. All new features are available to them.

IMPORTANT
You cannot migrate back to old applications. If you have any issues with the migration, please contact our support team.

You can find more details on migrating an application in the Python Selector documentation.

New modern UI

Here’s a preview of our fresh, clear, and user-friendly client Python Selector UI—enjoy it!

Python Selector

Python Selector

What’s next

We are still developing our Python Selector and would really like to know what you think about these features:

  • Execute command in the application’s virtual environment in the UI

    We are considering whether it’s really needed because it lets end-users bypass disabled any SSH restrictions set by the administrator. However, it is available in the old Python Selector.

  • Remove one module from the application’s virtual environment

    Currently, you can do this only via the CLI, using either with the cloudlinux-selector uninstall-modules command or directly with the pip command in the activated virtual environment. We are considering implementing this feature in the UI in the future.

  • Switch application version in the administrator UI

    For now, the administrator is not allowed to change the application version; only the user can do that. But the user can have some old applications that were not migrated to the new Python Selector and the administrator should have the ability to switch application version for those old applications.

Disabled Functionality

We found some outdated functionality and see no reason to continue supporting it:

  • backward compatibility of the new Python Selector with the selectorctl command line tool
  • the ability to install separate modules via UI will be disabled
  • the ability to run any command from UI will be disabled for security reasons

We’ll be more than happy if you take part in a survey regarding the Python Selector. You can find it here.

Update command

yum update lvemanager --enablerepo=cloudlinux-updates-testing

Downgrade command

yum downgrade lvemanager

Changelog

alt-python27-cllib-1.5.7-1

  • PTCLLIB-152: import Python applications should not fail on DirectAdmin

lvemanager-5.0.1-1

  • implemented New Python Selector
Beta: Alt-Node.js updated
Alt-PHP updated
 

Comments

No comments made yet. Be the first to submit a comment
Already Registered? Login Here
Guest
Monday, 22 July 2019

Captcha Image