CloudLinux OS Blog

Beta Node.js Selector is now available for DirectAdmin!

Beta Node.js Selector is now available for DirectAdmin!

I am happy to announce that the CloudLinux OS team has delivered Node.js Selector for our dear DirectAdmin customers, and it is now available in our beta release.

As JavaScript became one of the most popular programming languages, more and more customers demand Node.js hosting. With CloudLinux Node.js Selector for DirectAdmin, your customers are now able to host their JavaScript applications using Node.js 6, 8 or 9.

Node.js Selector has a friendly UI that unites all of the features in one place which makes it very convenient to manage.

While the Node.js Selector supports Node.js versions ranging from 6.x to 9.x and later. One thing you will also have to make sure to install is LVE Manager 4.0 (or later).

Watch out for the updates we post on social media so as to be the first to see the latest news about the Node.js Selector updates or any other valuable improvements!

And do join our webinar Why you should offer Node.js Hosting and how to roll it out on Wednesday, May 23rd at 12 pm EST.

We encourage you to help us with beta testing and to install this feature on your servers. We’d be extremely grateful for any feedback provided! Please do not hesitate to drop a line to This email address is being protected from spambots. You need JavaScript enabled to view it..

To update run:

yum update cagefs lvemanager lve-utils alt-python27-cllib --enablerepo=cloudlinux-updates-testing

Changelog:

alt-python27-cllib-1.4-8.1

  • PTCLLIB-117: reworked DirectAdmin cpapi plugin according to DirectAdmin improvements;
  • PTCLLIB-116: added a method to unmount directory in cagefs.mp;
  • LU-735: added an ability to use additional domains in DirectAdmin for create Node.js applications;
  • LU-737: remount_proc.py does not now ignore fs.proc_super_gid in /etc/sysctl.d/* files;
  • LU-732: fixed subdomains in hook for changing main domain.

cagefs-6.1-21

  • LU-726: added git to CageFS in order to install git packages using npm;
  • CAG-808: excluded virtfs mounts from CageFS.

lve-utils-3.0-12

  • LU-661: implemented locking for Node.js applications;
  • LU-731: fixed detection of H-Sphere;
  • LU-662: implemented locking for Node.js applications;
  • LU-737: remount_proc.py does not now ignore fs.proc_super_gid in /etc/sysctl.d/* files;
  • LU-693: "selectorctl --interpreter nodejs" command now prints "please use cloudlinux-selector utility instead";
  • LVEMAN-1260: "--new-app-uri" is now optional when moving an application to a new domain only.

lvemanager-4.0-15.1

  • LVEMAN-1272: investigated and fixed an issue when Node.js applications become hidden after adding a user into CageFS;
  • LU-746: added an ability to change domains for application even if it is an alias of previous domain;
  • WEB-997: dimensions for EntryProcs limit are not used now;
  • WEB-991: fixed visual issues on pop-ups and hints for Node.js tab on DirectAdmin;
  • WEB-993: fixed CSS issue for dropdown "Node.js version" in the user's part of Node.js Selector;
  • LVEMAN-1281: /usr/share/l.v.e-manager/cpanel/hooks/l.v.e-manager_postupcp_hook.sh does not break dynamicui.conf now;
  • WEB-992: fixed search functionality in Options tab for ability to use any particular symbols in searching phrase;
  • WEB-988: an access to reseller’s plugin for DirectAdmin admin introduced by a reseller is restricted;
  • WEB-928: created user’s UI of Node.js Selector for DirectAdmin (fix);
  • LVEMAN-1256: forbidden to specify "package.json" file in the Application startup file for Node.js Selector;
  • LVEMAN-1274: added an ability to use subdomains on DirectAdmin to create Node.js applications;
  • LU-732: fixed subdomains in hook for changing main domain;
  • LU-718: an application now transits to a new domain when the domain is renamed in DirectAdmin;
  • PTCLLIB-115: fixed alt-python* postinstall scriptlet;
  • LU-726: added git to CageFS in order to install git packages using npm;
  • LVEMAN-1262: Python Selector: fixed pip error "no such option: --allow-all-external";
  • LVEMAN-1241: cl-quota -YC cron job resets soft limit grace period;
  • WEB-937: fixed an issue with accordion on Options tab;
  • WEB-849: implemented search functionality in Options tab;
  • WEB-791: added a possibility to manage users limits from "Current Usage" in reseller's plugin;
  • WEB-965: fixed an issues when trying to create new Node.js application;
  • WEB-944: it is not possible now to trigger npm packages installation by clicking outside "Run NPM Install" button;
  • WEB-945: improved the behavior of "Run NPM Install" button for end-user UI of Node.js Selector;
  • LU-693: "selectorctl --interpreter nodejs" command now prints "please use cloudlinux-selector utility instead";
  • WEB-949: fixed displaying of an error message in Selector tab when CageFS is not installed yet;
  • WEB-956: adapted test system for new build system (fix);
  • WEB-966: fixed "run js script" with parameters functionality;
  • WEB-932: fixed a placement of the message about disabling for Node.js;
  • WEB-958: resolved a conflict during running Admin's tests in parallel flow;
  • WEB-968: improved Node.js tests to detect full Node.js version;
  • WEB-956: adapted test system for new build system;
  • WEB-938: fixed an isuue when PHP Selector does not work under admin user in Plesk;
  • WEB-962: fixed "Error: Domain context is not initialized" trying to open LVE Manager when admin logged in as reseller on Plesk 17.8;
  • LVEMAN-1260: "--new-app-uri" is now optional when moving an application to a new domain only;
  • WEB-930: the page "plugin is not available" is now displayed for users in case when Node.js Selector is disabled;
  • WEB-943: reseller's "Options" tab is covered by integration tests;
  • WEB-872: fixed an issue when input fields for MySQL Governor are not hiding/appearing when turning On/Off 'Tracking user by MYSQL Governor';
  • WEB-890: implemented autotests for reseller's "Current Usage" tab;
  • WEB-911: changed request for enabling/disabling of Node.js version;
  • WEB-915: corrected text in LVE Manager for DB Governor configuration;
  • WEB-920: removed old LVE Manager plugin's files after updating to SPA version in DirectAdmin;
  • WEB-923: improved progress bar while "cache init" for Node.js on the Options tab of LVE Manager;
  • WEB-929: got rid of prototype dependency in Plesk for LVE Manager;
  • WEB-933: improved a behavior of "Choose version" dropdown on Node.js tab - admin UI;
  • WEB-939: fixed functional buttons in forms for editing Node.js applications;
  • WEB-936: improved editing of application in user's side of Node.js Selector;
  • WEB-934: improved the transition from versions' list to applications' list in admin part of Node.js Selector;
  • WEB-928: created user's UI of Node.js selector for DirectAdmin.

Topic: CloudLinux OS Blog , Tags: #DirectAdmin, #NodeJS Selector, #beta,

1982 people viewed this

Comments

 
No comments yet

Leave your comment

Guest, Tuesday, 23 October 2018

Captcha Image