CloudLinux OS Blog - Beta: MySQL 8.0 for MySQL Governor released
CloudLinux OS Blog

Beta: MySQL 8.0 for MySQL Governor released

Beta: MySQL 8.0 for MySQL Governor released

A new MySQL 8.0.13-1 package for MySQL Governor is now available for download from our updates-testing repository.

Changelog:

governor-mysql 1.2-37

  • added support for mysql80, libmysqlclient.so.21;
  • MYSQLG-297, MYSQLG-301: old authentification procedure for mysql80;
  • MYSQLG-293: added logrotate config for governor-mysql;
  • MYSQLG-306: fixed an error logging from --dbupdate;
  • MYSQLG-300: CageFS force-update after MySQL Governor installation and delete procedure;
  • MYSQLG-302: investigated why db_governor fails with error "Can't init BAD list";
  • MYSQLG-326: wrong handling of SQL line while logging slow MySQL query.

To install MySQL 8.0 run:

# yum install governor-mysql alt-php-config --enablerepo=cloudlinux-updates-testing
# yum groupupdate alt-php --enablerepo=cloudlinux-updates-testing
# /usr/share/lve/dbgovernor/mysqlgovernor.py --mysql-version=mysql80
# /usr/share/lve/dbgovernor/mysqlgovernor.py --install-beta

Notes:

  • MySQL 8.0 is supported since MySQL Governor 1.2-37.
  • Do not upgrade to version 8.0 servers earlier than 5.7.
  • cPanel does not officially support MySQL 8.0, that is why we don’t recommend to use it on cPanel servers.
  • Use on your own risk for DirectAdmin and Plesk servers, because downgrade can corrupt your databases.
CloudLinux 6 kernel updated
New ISPmanager Lite panel with ImunifyAV
 

Comments

No comments made yet. Be the first to submit a comment
Already Registered? Login Here
Guest
Wednesday, 21 August 2019

Captcha Image